[Dnsmasq-discuss] Local domains and local hosts

Jima jima at beer.tclug.org
Fri Sep 21 14:46:50 BST 2007

On Fri, 21 Sep 2007, Simon Kelley wrote:
> I've tried the above with dnsmasq 2.40, and it seems to work correctly
> (no error). I don't recall specifically fixing this, but it might have
> been fixed as a side-effect of other work. What version of dnsmasq are
> you using?

  First I tried this on one of my OpenWRT devices (since I knew I had an 
old version of dnsmasq on it).  Reproduced.  Then I tried it on my 2.40 
install...and reproduced it again.  Yeah, suffice it to say I was 
confused.  However, I did finally figure out what the problem was.
  It's IPv6.  Evidently the address= line causes dnsmasq to respond 
NXDOMAIN to IPv6 queries for the hostname.  I added a second address= line 
pointing to an IPv6 address, and lo and behold, the `host` command returns 
successfully (and with both addresses).
  I'm not sure what conditions are necessary to trigger this bug, whether 
it just requires IPv6 support to be loaded, or if you actually need a 
working IPv6 network (which I have).  But, I'm pretty sure that's the root 
of the problem.


More information about the Dnsmasq-discuss mailing list