[Dnsmasq-discuss] Can't serve more than 1 local domain

Holger Schletz schletz at zfg-dortmund.de
Tue Oct 21 12:36:44 BST 2008


I'm using dnsmasq 2.35 on Debian to serve a local domain. This has 
worked for a long time without problems. Now I want to serve a second 
domain as an alias for the old domain. I use this option:


After restarting dnsmasq, the logfile says, as expexted:

using local addresses only for domain newdomain
using local addresses only for domain olddomain

Querying hosts from olddomain still works, but newdomain always gives me 

# dig @localhost validhostname.newdomain A

; <<>> DiG 9.3.4-P1.1 <<>> @localhost validhostname.newdomain A
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 14043
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;validhostname.newdomain.          IN      A

;; Query time: 1 msec
;; WHEN: Tue Oct 21 13:11:43 2008
;; MSG SIZE  rcvd: 38

I also tried adding newdomain to the search option in resolv.conf 
without success.

What am I doing wrong?

More information about the Dnsmasq-discuss mailing list