[Dnsmasq-discuss] VPN DNS prioritization

Tom Metro tmetro+dnsmasq at gmail.com
Sat Jul 11 23:32:52 BST 2009


David Schnur wrote:
>> Why isn't DHCP enabled for that connection?
> 
> I was surprised by that, too, since I am getting assigned an address; I 
> don't have anything set manually for that connection.

If that interface is really using PPP as indicated, I seem to recall 
that PPP included its own mechanism for assigning the IP address.


> I tried unsetting the domain option... The only thing I noticed is
> that, with the router, the 'DNS Suffix Search List' entry is not
> present.  With Dnsmasq, it's always present, although empty if the
> dnsmasq.conf domain option is not set.

Perhaps Dnsmasq is sending the domain DHCP option always, just with an 
empty value, while the router is excluding that option from the packet. 
(If you feel adventurous, a packet sniffer (Wireshark) can answer that 
question.)

In any case, having a suffix present should be common, so either it is a 
real fragile hack, or something else is the underlying cause of it breaking.


>> Have you tried specifying the DNS servers statically?
> 
> That's actually a really simple solution, and it works as expected. 

Great.


> In any case, this seems like mainly a Windows issue;

Yup. You'll probably get better answers in other forums. But if you get 
to the bottom of it, let us know what you find.


> Thanks for your help!

You're welcome.

  -Tom
-- 
Tom Metro
Venture Logic, Newton, MA, USA
"Enterprise solutions through open source."
Professional Profile: http://tmetro.venturelogic.com/



More information about the Dnsmasq-discuss mailing list