[Dnsmasq-discuss] router won't query itsself

JD jd1008 at gmail.com
Wed Aug 12 16:52:31 BST 2009

On 08/11/2009 09:08 PM, Santiago Zarate wrote:
> Looks like to me, that in your resolv.conf there's no line pointing to the nameserver
> itself...
> Are you sure you have this line: nameserver
> just in case... restart dnsmasq again
> :)
> On Mar 11 Ago 2009 19:00:56 Christ Schlacta escribió:
>> >  my router running dnsmasq won't query itsself.  any machine on the
>> >  network can run "ping oldbaz" and the router will return the proper IP
>> >  address and pinging will ensue.  when I run "ping oldbaz" from my
>> >  router, no ping love occurs:(   I've tried a number of things, including
>> >  listing and my router's IP address in the resolv.conf file,
>> >  and none of it seems to help.
>> >

/etc/resolv.conf must ONLY contain


/etc/dnsmasq.conf   must set


Or whatever you decide to call that file, which contains the list of the 
real nameservers.

If you do not want to set this in /etc/dnsmasq.conf , then you must
specify it on the command line that starts dnsmasq. In 
/etc/init.d/dnsmasq, it is started  as

         echo -n "Starting dnsmasq: "
         daemon $dnsmasq $OPTIONS
In my case, it turns out that $OPTIONS is an empty string, and does not 
contain my domainname.

So to specify the resolver file on the command line, just add
         daemon $dnsmasq -r /etc/resolv.dnsmasq $OPTIONS

After that

sudo service dnsmasq restart

Good luck

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/attachments/20090812/301e521b/attachment.htm 

More information about the Dnsmasq-discuss mailing list