[Dnsmasq-discuss] can resolve 1 specific host

Simon Kelley simon at thekelleys.org.uk
Sun Nov 15 12:18:58 GMT 2009

knud.skrald at guldberg.info wrote:
> Hi
> From time to time I get problmem with one host name
> www.dba.dk and camping.dba.dk
> They can not be solved, seems to be locked in some way on my dnsmasq
> server.
> A snip (reduced) of my log file is attached.
> Knud
> ------------------------------------------------------------------------
> _______________________________________________
> Dnsmasq-discuss mailing list
> Dnsmasq-discuss at lists.thekelleys.org.uk
> http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

Nov 14 20:58:46 dnsmasq[21682]: query[A] www.dba.dk from
Nov 14 20:58:46 dnsmasq[21682]: forwarded www.dba.dk to
Nov 14 20:58:46 dnsmasq[21682]: reply www.dba.dk is

That looks good.....

Nov 14 20:58:59 dnsmasq[21682]: query[A] camping.dba.dk from
Nov 14 20:58:59 dnsmasq[21682]: forwarded camping.dba.dk to
Nov 14 20:58:59 dnsmasq[21682]: reply camping.dba.dk is <CNAME>
Nov 14 20:58:59 dnsmasq[21682]: reply www.dba.dk is NODATA-IPv4

Now we look up camping.dba.dk, and get back the answer that
camping.dba.dk is a CNAME for www.dba.dk, and no data for www.dba.dk.
This means that the domain www.dba.dk exists, but there is no "A" record
for it. That information is cached, so future attemps to look up
www.dba.dk or camping.dba.dk fail, because dnsmasq "knows" that
www.dba.dk has no data.

There's clearly something wrong in the upstream server at, since it gave the correct data to the first request.

I've tried a query to and I get the correct information,
so it could be a problem which has been resolved:

srk at spike$ dig @ camping.dba.dk

; <<>> DiG 9.5.1-P3 <<>> @ camping.dba.dk
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19814
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 4, ADDITIONAL: 4

;camping.dba.dk.			IN	A

camping.dba.dk.		600	IN	CNAME	www.dba.dk.
www.dba.dk.		1444	IN	A

running this query through my local dnsmasq causes the correct thing to
be cached.

Summary: the problem seems to be in the upstream nameserver, but it's OK
now. If you are still hitting problems, try restarting dnsmasq to clear
out the bad cache entries, and try again: If it's still broken, complain
to whoever runs that nameserver.



More information about the Dnsmasq-discuss mailing list