[Dnsmasq-discuss] proxy dhcp does not send dhcp-options

Jochen Dekeyser jochen.dekeyser at gmail.com
Mon Apr 9 17:59:46 BST 2012


I forgot to mention I tried this with version 2.48 on CentOS6 and
version 2.52 on Fedora 14.

Jochen

On Mon, Apr 9, 2012 at 6:46 PM, Jochen Dekeyser
<jochen.dekeyser at gmail.com> wrote:
> I already tried to use dhcp-option-force but it does not make any difference...
>
> My testcase (= dnsmasq as full dhcp vs dnsmasq as proxy dhcp) was
> tested on the same client, so the full dhcp sends dhcp-options, the
> proxy dhcp does not send my dhcp-options...
>
> I now even checked it with Wireshark and the client does ask for all
> the specified parameters (and lots of others)...
>
> Thx for reply!
> Jochen
>
>
> On Mon, Apr 9, 2012 at 6:05 PM, Simon Kelley <simon at thekelleys.org.uk> wrote:
>>
>> The problem might be that the option numbers in question are not being
>> requested by the client. This is easy to fix by using dhcp-option-force
>> intsead of dhcp-option, so  that options are sent anyway.
>>
>> HTH
>>
>> Simon.
>>



More information about the Dnsmasq-discuss mailing list