[Dnsmasq-discuss] proxy dhcp does not send dhcp-options

Simon Kelley simon at thekelleys.org.uk
Mon Apr 9 18:06:56 BST 2012

On 09/04/12 17:59, Jochen Dekeyser wrote:
> I forgot to mention I tried this with version 2.48 on CentOS6 and
> version 2.52 on Fedora 14.
> Jochen
> On Mon, Apr 9, 2012 at 6:46 PM, Jochen Dekeyser
> <jochen.dekeyser at gmail.com>  wrote:
>> I already tried to use dhcp-option-force but it does not make any difference...
>> My testcase (= dnsmasq as full dhcp vs dnsmasq as proxy dhcp) was
>> tested on the same client, so the full dhcp sends dhcp-options, the
>> proxy dhcp does not send my dhcp-options...
>> I now even checked it with Wireshark and the client does ask for all
>> the specified parameters (and lots of others)...
>> Thx for reply!
>> Jochen
>> On Mon, Apr 9, 2012 at 6:05 PM, Simon Kelley<simon at thekelleys.org.uk>  wrote:
>>> The problem might be that the option numbers in question are not being
>>> requested by the client. This is easy to fix by using dhcp-option-force
>>> intsead of dhcp-option, so  that options are sent anyway.
>>> HTH
>>> Simon.
I just looked at the code, and it doesn't attempt to include 
generally-specified options in the PXE-proxy reply, only the stuff 
required for the PXE protocol. Do you know that what you're trying to do 
is valid (ie send general options via the PXE-proxy reply, rather than 
have the client get them from the server which does address allocation.)?

It may be time to consult the Intel PXE specification. Abandon hope......



More information about the Dnsmasq-discuss mailing list