[Dnsmasq-discuss] Slow response to DHCPDISCOVER

Adrian May adrian.may at oregan.net
Tue Apr 24 04:21:39 BST 2012

Hi Simon,

In the meantime I installed ClearOS, which uses dnsmasq. Now the PCs get 
served fast but my embedded boards are still not getting IPs. If I plug 
these embedded boards into my 10 dollar domestic router, they get an IP 
instantly. I already tried setting bootp-dynamic and dhcp-broadcast in 
the config. If I grep everything under /var/log for dnsmasq, there's no 
evidence that requests were even received from these boards. So I still 
suspect the networking layer.

As for the boards themselves, I'm not entirely sure what they do. 
They've got some kind of embedded linux. One boots into yamon where I 
can only say "net init", the other into something of its own invention 
where I start udhcpc.

I tried no-ping but it had no effect. I can't get my brain around your 
tag system. I've just been writing things like bootp-dynamic with no 
tags right in the main config file, or in the case of ClearOS, in the 
dhcp config file which is referenced from the main config file. Could it 
be that these settings have no effect unless I attach some tags, or put 
them inside a subnet declaration?


On 04/23/2012 08:01 PM, Simon Kelley wrote:
> On 23/04/12 12:02, Adrian May wrote:
>> Hi all,
>> I get the same result with dnsmasq, dhcp3-server and isc, namely, that
>> the client has to send several DHCPDISCOVER packets before the server
>> finally responds after about 30 seconds. This is breaking a couple of
>> embedded platforms because they aren't that patient, and I have no way
>> of configuring that.
>> Why don't DHCP servers just respond to the first DHCPDISCOVER?
>> Especially when I made them authoritative?#
> Servers allocate an address and then ping it for a few seconds just to 
> be sure it's not in use. That's the main delay. In dnsmasq --no-ping 
> will stop this behaviour. Also the  client is entitled to wait around 
> collecting answers from more than one server before deciding which one 
> to use; they rarely do this and it doesn't sound like yours are.
>> I think I might have seen in the logs that the dhcp processes aren't
>> even getting the earlier packets, even though the machine is. It's as if
>> they get discarded by the networking layer. This is a ubuntu server
>> 10.04 machine.
> Firewall rules can affect things, but the result is rarely 
> intermittent. Is your network heavily loaded and dropping packets?
> Cheers,
> Simon.
>> Any ideas?
>> Adrian.
>> _______________________________________________
>> Dnsmasq-discuss mailing list
>> Dnsmasq-discuss at lists.thekelleys.org.uk
>> http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss
> _______________________________________________
> Dnsmasq-discuss mailing list
> Dnsmasq-discuss at lists.thekelleys.org.uk
> http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

More information about the Dnsmasq-discuss mailing list