[Dnsmasq-discuss] help needed in dnsmasq problem

richardvoigt at gmail.com richardvoigt at gmail.com
Thu May 17 19:38:32 BST 2012

It's not anything specifically wrong in the configuration file, but it
doesn't sound like it matches your network setup.

>From your question, I think you have some names that can only be
resolved by one of your nameservers?  And therefore you are concerned
when dnsmasq doesn't contact the server with the ability to resolve
those names.

But dnsmasq's list of upstream servers is designed for redundancy, and
it requires that any query can be sent to any arbitrary server and get
a correct answer.  There is not load balancing per se, but checks are
done to see which server on the list is the nearest/fastest, which
will tend to pick the least busy server, which is similar to load

If some queries must be sent to a single server, then you should
create per-domain rules that cause those queries to go to that server,
and not be handled by the global upstream.

"strict-order" will help determine if this is actually your problem,
because it causes queries to be sent to every server in turn.  But it
hurts performance, so adding domain-specific server entries is the
better way.

On Thu, May 17, 2012 at 11:32 AM, Atul Gupta <atul14.kumar at gmail.com> wrote:
> Please reply what you think is not correct in conf file.
> Thanks.
> On Thu, May 17, 2012 at 12:29 PM, richardvoigt at gmail.com
> <richardvoigt at gmail.com> wrote:
>> I think your configuration is wrong, but as a test, does the
>> "strict-order" option fix your problem?
>> On Thu, May 17, 2012 at 9:38 AM, Atul Gupta <atul14.kumar at gmail.com> wrote:
>>> Hi,
>>> One server in my dnsmasq.conf file is never tried for sending the query.
>>>   Below is my config file:-
>>>   # Management DNS servers [2]
>>>   server=/ody.engr.net/2001:5b0:ffff:fff6::25 at 2001:05b0:3efe:2e1f:0000:0000:004c:4d0d
>>>   server=/ody.engr.net/2001:5b0:ffff:fff6::26 at 2001:05b0:3efe:2e1f:0000:0000:004c:4d0d
>>>   address=/controlcenter.com/
>>>   address=/controlcenter.com/fd0d:edc3:e12a:0000::1
>>>   address=/www.odyagentid.com/
>>>   cache-size=1000
>>>   max-ttl=60
>>>   neg-ttl=60
>>>   no-resolv
>>>   max-ipperhost=5
>>>   server= at
>>>   server= at
>>>   server=2001:5b0:3eff:fff7::20 at 2001:05b0:3e1a:8000:0280:aeff:fe4b:0277
>>>   server=2001:5b0:3eff:fff7::20 at 2001:05b0:3e1a:8000:0280:aeff:fe4b:0277
>>>   I guess dnsmasq adds all servers in the daemon->servers list and picks
>>>   servers from there while forwarding the query. My question is that if
>>>   there is any scenario where dnsmasq removes any server from this
>>>   (daemon->servers) list.As this is what seems to happening in my case
>>>   i.e. server is never being tried to forward the query.
>>>   restart of dnsmasq solves this problem.
>>>   Also when this problem comes and dump cache, there is no entry for
>>> below is dump
>>>   cache size 1000, cache insertions 2644, re-used unexpired cache entries 0
>>>   queries forwarded 1301, queries answered locally 37
>>>   server 2001:5b0:ffff:fff6::25#53: queries sent 0, retried or failed 0, used 0
>>>   server 2001:5b0:ffff:fff6::26#53: queries sent 0, retried or failed 0, used 0
>>>   server 2001:5b0:3eff:fff7::20#53: queries sent 680, retried or
>>> failed 0, used 0
>>>   Host                                     Address
>>>    Flags     Expires
>>>   Please ignore the counters next to  "queries sent", "cache insertions"
>>>   etc. as they may be inconsistent, but real problem is that i don't see
>>> in this list.
>>>   Please help!!!!
>>>   Regards,
>>>   Atul.
>>> _______________________________________________
>>> Dnsmasq-discuss mailing list
>>> Dnsmasq-discuss at lists.thekelleys.org.uk
>>> http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

More information about the Dnsmasq-discuss mailing list