[Dnsmasq-discuss] dnsmasq doesn't provide IP address to udhcpc?

Simon Kelley simon at thekelleys.org.uk
Tue Nov 26 21:49:36 GMT 2013

On 26/11/13 21:29, Tom Isaacson wrote:
>> "what I've done to fix it" is easy. The first thing you tried
>> translates as "force broadcast mode when doing BOOTP". Since you're
>> not doing BOOTP, it makes no difference. The second attempt says
>> "force broadcast mode when NOT doing BOOTP" and unsurprisingly
>> works better. Best, would probably be to make it unconditional;
>> dhcp-broadcast
> I tried adding this to dnsmasq.conf but I get " missing parameter at
> line 5 of /etc/dnsmasq.conf". "dhcp-broadcast=" causes a segmentation
> fault.

You must have a very old version of dnsmasq. A quick check back through 
the changelog says that unconditional dhcp-broadcast went into 2.53, 
which is 3 years old.

>> As to why using broadcast works, but you never see an offer
>> otherwise, then that's more difficult. When not doing broadcast,
>> the DHCPOFFER has to be sent to an unconfigured host which can't
>> reply to ARP requests. To make this work dnsmasq stuffs the MAC
>> address, IP address, device triple into the ARP table "manually",
>> so that when it sends the DHCPOFFER to the kernel can
>> get it to the right place. My guess is that something is going
>> wrong in that process, but since it's worked well for over a
>> decade, I'm not sure what. Is there anything unusual about the
>> network interface and routing configuration on the the server box?
> The WAP is running a Ralink RT3050 with the Ralink SDK but it's being
> done for us by a Chinese manufacturer. Judging by the amount of
> testing and debugging I'm having to do it's entirely possible they
> done something weird without realising it!

Ask them for newer dnsmasq code, for a start!



More information about the Dnsmasq-discuss mailing list