[Dnsmasq-discuss] DHCP DNS Issues

Simon Kelley simon at thekelleys.org.uk
Sun Jan 26 21:56:48 GMT 2014

On 26/01/14 21:29, Robert Ferris wrote:
> I've got dnsmasq on my router (running tomato), doing DHCP and DNS.
> Lately, though, it's not resolving dynaic DHCP hostnames. It resolves
> hostnames for static DHCP assignments fine, and everything else seems to
> work fine, but it just forwards DHCP hostname DNS requests to the
> upstream server, which obviously then returns NXDOMAIN.
> Running:
> Dnsmasq version 2.58  Copyright (c) 2000-2011 Simon Kelley
> Compile time options IPv6 GNU-getopt no-RTC no-DBus no-i18n DHCP TFTP
> no-conntrack no-IDN
> I have a domain set in the conf file (vortex), with expand-hosts,
> stop-dns-rebind, rebind-localhost-ok, and dhcp-authoritative.
> Here are two example leases from the leases file:
> 75790 00:0c:29:3f:5e:c0 BAF-VM7 01:00:0c:29:3f:5e:c0
> 75432 00:0c:29:0b:d8:f0 magnetosphere *
> Neither of those hosts resolve. I've tried "BAF-VM7" "BAF-VM7."
> "BAF-VM7.vortex" and "magnetosphere" "magnetosphere." and
> "magnetosphere.vortex"
> I've restarted dnsmasq, released/renewed the leases, etc. Occasionally
> after restarting or releasing/renewing the lease, it will resolve for a
> short while. Sometimes if I try to reverse DNS the IP, it will come back
> with the hostname, and then sometimes it will start resolving that
> hostname for a short while, but for the most part, it simply doesn't
> work. This used to work, with the same configuration, and it was only
> recently that I noticed issues with it.
> If I run with log-queries and log-dhcp, I can see a machine getting a
> DHCP lease, and I can see the lookup requests coming in (and getting
> forwarded upstream). If I kill -USR1 it, the dynamic lease hostnames
> don't appear in the list, except for hosts where it randomly decides to
> work.
> Tomato isn't maintained for my router anymore, so there aren't any new
> versions to update to. Any ideas on getting this working again?

Just a hunch, look at the first number in /proc/uptime. It's supposed to 
be the number seconds that the machine has been uo, and it's what 
dnsmasq (in the no-RTC incarnation you're using) is using to age DHCP 
leases. Does it look reasonable, or is something making big jumps on the 

I'm not aware of any bugs, historical or otherwise, that manifest like this.



More information about the Dnsmasq-discuss mailing list