[Dnsmasq-discuss] SLAAC is working, but DHCPv6 isn't [SOLVED]

Ken Welker benedictcc at yahoo.com
Tue Nov 11 23:01:26 GMT 2014

On 10/30/2014 6:54 PM, Ken Welker wrote:

> Looks like this is still happening under version 2.72 (which I expected
> from the changelog, but still tested to be sure).  The syslog still says
> it is sending a DHCPADVERTISE with an IPv6 address in the correct range
> to the host, but packet captures on the server as well as the host don't
> show anything going out from the server.

I found out the problem, and thought I'd post it in case anyone else
runs into it.  It seems to be a Linux kernel issue, where flushing the
routing table and adding a new address doesn't automatically add the
default route for the interface's link local address.  Details and an
initial patch are at https://bugzilla.kernel.org/show_bug.cgi?id=68511

This was the reason that the DHCPv6 server wasn't replying back to the
client; unfortunately, there wasn't any logging I could find that
indicated a problem.  I didn't notice any other issues, so it took a
while to discover.

A simple workaround is to add the link local default route back when the
routing table is flushed.  Once I did that, DHCPv6 worked fine.

I'm glad to be able to continue to use dnsmasq, and in new ways. :-)


More information about the Dnsmasq-discuss mailing list