[Dnsmasq-discuss] rebind-domain-ok bug? Not whitelisiing 4 word domain.

Simon Kelley simon at thekelleys.org.uk
Fri Oct 18 13:14:35 BST 2019

On 14/10/2019 23:05, Michael wrote:
> Hi Simon,
> I'm using ASUS Merlin 384.13, which is compiled with dnsmasq
> 2.80-44-g608aa9f, on my router.   I have rebind protection on and want
> to whitelist "universal-web-internal.production.gannettdigital.com" as
> for some reason after upgrading to iOS 13 on my iOS devices that domain
> is getting hit very often.
> I added the following to the dnsmasq.conf file, but the domain is still
> being logged:
> rebind-domain-ok=/universal-web-internal.production.gannettdigital.com/
> I also tried:
> rebind-domain-ok=/.gannettdigital.com/
> That white lists "production.gannettdigital.com" (which also has a
> private ip address), but not
> "universal-web-internal.production.gannettdigital.com".
> As such, this appears to be a bug.  I'm not sure if dnsmasq doesn't like
> the dashes or the fact that there are 4 parts to the domain.
> Any idea why this isn't working?

No. A cursory attempt to reproduce it here failed. Could you post your
entire dnsmasq config, or email it to me privately if you prefer.

One thing: when I first tried this. I typed gannetdigital.com (without
the double-t). You didn't fall for the same typo, did you?


More information about the Dnsmasq-discuss mailing list