[Dnsmasq-discuss] dnsmasq and option 78

Kristian Evensen kristian.evensen at gmail.com
Mon Mar 9 12:09:48 GMT 2020


I am trying to configure dnsmasq to export DHCP option 78 (rfc2610) to
the clients on my network, but I am struggling to make it work. My
problems seems to be caused by the "Mandatory" byte that has to be
part of the option.

My initial attempt was to add the following to dnsmasq.conf:

However, this caused dnsmasq to fail with the following error message:
Mon Mar  9 11:55:55 2020 daemon.crit dnsmasq[3232]: bad IPv4 address
at line 38 of /etc/dnsmasq.conf

I then tried to replace "1" with 0x01 and 1b, but in my packet capture
I see that the values are sent as strings (so "0x01" and "1b"). I then
tried to just add 1 (so dhcp-option-force=78,1), which worked in the
sense that dnsmasq did not fail to start and an integer was sent to my

Has anyone managed to configure dnsmasq to export option 78 or know
how to combine an integer with an address list? My router is running
dnsmasq verson 2.80.

Thanks in advance for any help,

More information about the Dnsmasq-discuss mailing list