[Dnsmasq-discuss] warning: `dnsmasq' uses deprecated v2 capabilities in a way that may be insecure.

Simon Kelley simon at thekelleys.org.uk
Thu Jun 19 09:58:30 BST 2008


Posting here for googlers.......

It's come to my attention that running dnsmasq 2.42 under Linux kernel
2.6.25 (at least) causes the kernel to emit the message

warning: `dnsmasq' uses deprecated v2 capabilities in a way that may be
insecure.

For dnsmasq, this is a redundant warning and should be ignored: the code
in dnsmasq is _not_ insecure.

The next dnsmasq release will tweak the code again to suppress the warning.

Cheers,

Simon.



More information about the Dnsmasq-discuss mailing list