[Dnsmasq-discuss] Can't get dnsmasq to work on OS X 10.6 as DNS forwarder only

John Puffs johnnypuffs at gmail.com
Sat Jul 31 08:41:42 BST 2010

Hi -

I have spent the past two days trying every option and reading every man
page, discussions here, google searches, etc.

My situation is this.

I am running Snow Leopard latest 10.6.4

I am connected to the internet via a DSL router that assigns IPs with DHCP.

I am only concerned about one machine on the network.. mine

For example: my router ip/gateway is

The machine I am on is

I have a /etc/hosts file that is huge.

I want to keep the original /etc/hosts and set a additional hosts file with
all my blocks. I know I can point dnsmasq to read that additional file.

I installed Macports. I installed dnsmasq

I tried EVERYTHING I have read. Nothing works. I get:

failed to bind listening socket   Address already in use


failed to create listening socket   Address already in use

It seems like it would be a simple setup

What exactly do I need t do.

1. Does my router firewall need to open ports for dnsmasq?
2. I have in my hosts and resolv.conf
3. Do I need to change something in Preferences, Networks?
4. What options do I set in dnsmasq.conf? I have tried SO many

Anything else.

FYI: I am NOT an admin or programmer. I know enough only to be dangerous...

ANY help would be much appreciated.

Thanks so much!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/attachments/20100731/c5818ac0/attachment.htm 

More information about the Dnsmasq-discuss mailing list