[Dnsmasq-discuss] Windows 7 machine does not look up correctly.

Roland Giesler roland at giesler.za.net
Tue Jun 18 15:35:02 BST 2013


I don't have windows machines to test this with, except this client's
notebook that is causing this.  Can any help with this?  I'm at my
whit's end with the strange behaviour.

regards

Roland

On Wed, Jun 12, 2013 at 1:24 PM, Roland Giesler <roland at giesler.za.net> wrote:
> I have an Ubuntu 12.04 server with dnsmasq serving dns lookups and dhcp
> addresses.  It works 100% for the Linux machines that connect to it, but a
> Windows 7 machine is not able to look up dns for most domains.
>
> My config files contain:
>
> $ sudo egrep -vr "^$|^#" /etc/dnsmasq*
> /etc/dnsmasq.conf:interface=br0
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:port=53
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:log-dhcp
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:log-queries
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:tftp-root=/var/lib/tftpboot
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-boot=/ltsp/i386/pxelinux.0
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-option=17,/opt/ltsp/i386
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-no-override
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:pxe-prompt="Press F8 for boot menu",
> 3
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:pxe-service=X86PC, "Boot from
> network", /ltsp/i386/pxelinux
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:pxe-service=X86PC, "Boot from local
> hard disk", 0
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-range=192.168.8.101,192.168.8.150,255.255.255.0,12h
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=44:4d:50:02:ed:ee,192.168.8.101,appollis-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=00:00:00:00:00:00,192.168.8.102,betsie-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=00:1b:eb:59:28:1b,192.168.8.103,rozanne-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=00:1b:eb:59:28:27,192.168.8.104,muneerah-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=44:4d:50:02:ed:ed,192.168.8.105,mona-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=00:1b:eb:59:28:19,192.168.8.106,alta-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=00:1b:eb:49:59:50,192.168.8.107,wendy-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-host=52:54:00:af:ad:96,192.168.8.111,test-tc,infinite
> /etc/dnsmasq.d/ltsp-server-dnsmasq.conf:dhcp-option=252,"\n"
> /etc/dnsmasq.d/libvirt-bin:bind-interfaces
> /etc/dnsmasq.d/libvirt-bin:except-interface=virbr0
>
> As can be seen, I have enabled logging of queries.  Here are the last few
> lines of /var/log/syslog wrt dnsmasq entries when a web site is accessed
> from the windows machine:
>
> Jun 12 13:14:34 zambas dnsmasq[10820]: query[A] www.google.com from
> 172.16.1.3
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.59
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.55
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.54
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.50
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.49
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.45
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.44
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.40
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.39
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.35
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.34
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.30
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.29
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.25
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.24
> Jun 12 13:14:34 zambas dnsmasq[10820]: cached www.google.com is
> 197.84.128.20
>
> This is the only domain that the Windows 7 machine can lookup.
>
> All other result in domain not found in the browser.  This it the case for
> both Firefox and IE.
>
> However, doing an nslookup works fine, as well as a ping.
>
> The dns is set correctly and the machine also gets it's ip address from
> dnsmasq.
>
> What could be preventing the windows webbrowsers from getting dns lookups
> done?
>
> regards
>
> Roland Giesler
>



More information about the Dnsmasq-discuss mailing list