[Dnsmasq-discuss] LAN taken down by Ubuntu upgrade - can't see problem

Adam Hardy adam.ant at cyberspaceroad.com
Sun Jun 30 16:55:47 BST 2013

adam.ant at cyberspaceroad.com on 6/29/2013 5:45 PM, wrote:
> I upgraded the OS on my gateway machine which runs dnsmasq serving dhcp
> and dns to the lan, and now the machines on my lan can't get an ip
> address.
> With ubuntu, I run dnsmasq in a stand-alone mode, in contrast to the
> ubuntu 'way' where the default installation installs dnsmasq and sets it
> up for optimal desktop networking - which doesn't work well for a gateway
> machine.
> My lan is on eth1, my modem is on eth0. Eth1 is assigned by
> /etc/network/interfaces, and this is what dnsmasq is configured to run on.
> I hope you can give me a hint where to look next because as far as I am
> aware, the only thing that changed was the ubuntu upgrade and I'm not
> getting any help from the forum there, and my investigations with my
> limited experience has run into the sand.[SNIP]

OK problem solved, it was just my network hub that had on the blink and as it 
was buried under a mound of cables, I hadn't seen the blinking red light - 
strange co-incidence that it happened exactly as I did the ubuntu upgrade.

Anyway, a question that arises from my investigations:

I installed dhcping and running this command on the server with dnsmasq on produces the response "no answer" - surely I probe the DHCP service 
from the same machine like that?

More information about the Dnsmasq-discuss mailing list