[Dnsmasq-discuss] iPXE with DHCPv6

Derek Higgins derekh at redhat.com
Mon Feb 27 11:57:27 GMT 2017

Meant to close out this thread a while back, see below

On 27 January 2017 at 17:38, Tore Anderson <tore at fud.no> wrote:
> * Derek Higgins
>> I've been trying lately to get iPXE to work over DHCPv6 with dsnmasq
>> and have had no luck, Is it possible to do this with dnsmasq and
>> DHCPv6 and if so are there any examples out there?
>> I've been trying
>>   --dhcp-option="option6:bootfile-url,http://[1:2::3:4]:8088/boot.ipxe"

as it turned out the problem was that the IP I was using (1:2::3:4 was
an example), had a section with leading a zero and another without.
The UEFI firmware that I was using doesn't allow this

in other words
fc00:0101::1 - Wont work
fc00:101::1 - Worked fine

I then hit another problem, but I'll start another thread about it.

>> with a combination of different things, none of which I've gotten to
>> work, tcpdump shows the bootfile-url at least being sent in the dhcp6
>> advertise but then the UEFI firmware seems to ignore it
> Have you tried using a tftp:// URL instead of http://? Not sure you can
> rely on a UEFI firmware to implement HTTP.
> Tore

More information about the Dnsmasq-discuss mailing list