[Dnsmasq-discuss] Local dnsmasq server not utilized by Ubuntu

Chris Green cl at isbd.net
Sun Aug 4 16:08:44 BST 2019


On Sun, Aug 04, 2019 at 09:57:19AM -0400, dnsmasqyq.xpt at neverbox.com wrote:
> Hi,
> 
> I know this is not a dnsmasq issue per se, but all my machines are
> Ubuntu based and they all can't utilized the local dnsmasq server that
> I setup for my LAN, which literally making my local dnsmasq server
> useless.
> 
I run dnsmasq in a machine on my mostly xubuntu LAN so my set-up
should work for you too.


> The problem is that the NetworkManager that Ubuntu uses insists to use
> its own DNS server, which is 127.0.0.53, not the DHCP/DNS server I
> setup for my LAN.
> 
That's the 'local to the machine' caching DNS server and that's the
way it should be.


> I'm wondering how you guys solved such problems, since you are using
> dnsmasq server just fine. I had been asking such questions at the
> Ubuntu and NetworkManager side multiple times at multiple places, but
> have never been able to get a straight/working answer.
> 
What you (probably, almost certainly) need to do is turn off the DHCP
server that's already running on your LAN.  It'll be in the router
that connects you to the internet most probably.

Then, as long as *your* dnsmasq is running in one of the machines on
the LAN and is configured to provide DHCP (not the default, you have
to uncomment the 'dhcp-range' line in dnsmasq.conf) you should find
that everything will start working as you want.  Machines will need to
be rebooted (or wait a long[ish] time) to start using dnsmasq.

If the above doesn't work then keep asking questions, with more
detailed information about your set-up, and I'm sure answers will be
forthcoming.


-- 
Chris Green



More information about the Dnsmasq-discuss mailing list