[Dnsmasq-discuss] How to Add max-ttl in DNSMASQ

OMair Siddiquii omairsiddiqui55 at hotmail.com
Mon Oct 11 17:41:12 UTC 2021


  1.  I stopped DNSMASQ service.
  2.  I ran "dnsmasq --max-ttl=30"
  3.  Got this error "dnsmasq: bad command line options: try --help"
  4.  Tried to manually add max-ttl=<time> in dnsmasq.conf
  5.  Got this error "Starting dnsmasq:
dnsmasq: bad option at line 56 of /etc/dnsmasq.conf [FAILED]"

________________________________
From: Dnsmasq-discuss <dnsmasq-discuss-bounces at lists.thekelleys.org.uk> on behalf of Matus UHLAR - fantomas via Dnsmasq-discuss <dnsmasq-discuss at lists.thekelleys.org.uk>
Sent: Monday, October 11, 2021 9:25 PM
To: dnsmasq-discuss at lists.thekelleys.org.uk <dnsmasq-discuss at lists.thekelleys.org.uk>
Subject: Re: [Dnsmasq-discuss] How to Add max-ttl in DNSMASQ

On 11.10.21 16:01, OMair Siddiquii wrote:
>Even after upgrading to version 2.85 it didn't work.

what exactly does "didn't work" mean?
does dnsmasq still refuse to start?
do you have any error message?
did you try to stop it before starting?


>On 11.10.21 13:13, OMair Siddiquii wrote:
>>I am trying to add the max-ttl= parameter within the DNSMASQ config file
>> but unfortunately when I'm starting the dnsmasq service it fails to start
>> the dnsmasq process.  I am following the document mention in the link
>> below.  I am using DNSMASQ version 2.48 "Dnsmasq version 2.48  Copyright
>> (C) 2000-2009 Simon Kelley".  I also tried version 2.85 but it didnt work
>> either.  I would really appreciate any help.

>that's very old and very buggy version.
>according to the changelog, --max-ttl parameter was added in 2.53


--
Matus UHLAR - fantomas, uhlar at fantomas.sk ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
"Two words: Windows survives." - Craig Mundie, Microsoft senior strategist
"So does syphillis. Good thing we have penicillin." - Matthew Alton

_______________________________________________
Dnsmasq-discuss mailing list
Dnsmasq-discuss at lists.thekelleys.org.uk
https://lists.thekelleys.org.uk/cgi-bin/mailman/listinfo/dnsmasq-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/attachments/20211011/6bddfb22/attachment.htm>


More information about the Dnsmasq-discuss mailing list