[Dnsmasq-discuss] How to Add max-ttl in DNSMASQ

Petr Menšík pemensik at redhat.com
Tue Oct 12 09:24:23 UTC 2021


Please report what is on line 56.

Following command would print just that:

sed -e '56!d' /etc/dnsmasq.conf

I doubt that is about max-ttl option. Are you still using RHEL6 (or
derivate) for some reason? I thought every option is supported in more
recent versions. I would like to know what option were supported in the
old but is not in current version. Please Share.

Cheers,
Petr

On 10/11/21 19:41, OMair Siddiquii wrote:
>
>  1. I stopped DNSMASQ service.
>  2. I ran "dnsmasq --max-ttl=30"
>  3. Got this error "dnsmasq: bad command line options: try --help"
>  4. Tried to manually add max-ttl=<time> in dnsmasq.conf
>  5. Got this error "Starting dnsmasq:
>     dnsmasq: bad option at line 56 of /etc/dnsmasq.conf [FAILED]"
>
>
> ------------------------------------------------------------------------
> *From:* Dnsmasq-discuss
> <dnsmasq-discuss-bounces at lists.thekelleys.org.uk> on behalf of Matus
> UHLAR - fantomas via Dnsmasq-discuss
> <dnsmasq-discuss at lists.thekelleys.org.uk>
> *Sent:* Monday, October 11, 2021 9:25 PM
> *To:* dnsmasq-discuss at lists.thekelleys.org.uk
> <dnsmasq-discuss at lists.thekelleys.org.uk>
> *Subject:* Re: [Dnsmasq-discuss] How to Add max-ttl in DNSMASQ
>  
> On 11.10.21 16:01, OMair Siddiquii wrote:
> >Even after upgrading to version 2.85 it didn't work.
>
> what exactly does "didn't work" mean?
> does dnsmasq still refuse to start?
> do you have any error message?
> did you try to stop it before starting?
>
>
-- 
Petr Menšík
Software Engineer
Red Hat, http://www.redhat.com/
email: pemensik at redhat.com
PGP: DFCF908DB7C87E8E529925BC4931CA5B6C9FC5CB
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/attachments/20211012/09b0c318/attachment.htm>


More information about the Dnsmasq-discuss mailing list