<div dir='auto'>Solved adding fqdn to etc/host in the Ubuntu server.<div dir="auto"><br></div></div><div class="gmail_extra"><br><div class="gmail_quote">Il 28 gen 2017 11:48, cristian@studioautoservice.it ha scritto:<br type="attribution"><blockquote class="quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="auto">I do apologize. Further investigation took me to my Windows XP clients that seems to append to every host request the local domain ( we are dismissing a Windows domain but the machine are still joined).<div dir="auto">So if I ping testhost XP will add Autoservice.locale to the request.</div><div dir="auto">I tried adding local=Autoservice.local to dnsmasq.conf but didn't work.</div><div dir="auto">I hope that after unjoined the client will work as expected.</div><div dir="auto">Thanks anyway.</div><div dir="auto"><br /></div></div><div><br /><div class="elided-text">Il 27 gen 2017 20:59, cristian@studioautoservice.it ha scritto:<br /><blockquote style="margin:0 0 0 0.8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="auto">Hi everyone,<div dir="auto">I'm trying to make dnsmasq work in my small office.</div><div dir="auto">It's installed on Ubuntu machine.</div><div dir="auto">Everything seems ok I can resolve host names of the other PC's.</div><div dir="auto">The only thing I'd like to fix now is that I have to put a dot at the end of the host name otherwise it will not be resolved.</div><div dir="auto">So basically if I ping 'testhost' it fail if I ping 'testhost.' It will work.</div><div dir="auto">There must me something about domain name but I need some help.</div><div dir="auto">Thanks in advance.</div><div dir="auto"><br /></div></div></blockquote></div><br /></div></blockquote></div><br></div>