[Dnsmasq-discuss] tftp: No netascii support

Simon Kelley simon at thekelleys.org.uk
Fri May 23 21:32:14 BST 2008

Άλκης Γεωργόπουλος wrote:
> I tried to use dnsmasq in Ubuntu hardy with LTSP (thin clients), to
> replace dhcp3-server and tftp and of course to also add dns.
> The clients didn't get a necessary file named "lts.conf" because the
> script that tried to download it from tftp did:
> tftp server
> get lts.conf
> This is interpreted as a "netascii" transfer and dnsmasq replied
> "Unsupported operation" or something like that.
> So I had to change this script to:
> tftp server
> binary
> get lts.conf
> to force "octet" mode, which is supported, and everything worked like a charm.
> So, to make it work out of the box in these situations, please support
> "netascii" transfer mode, even if dnsmasq still sends the files as
> binary.
> Thanks for your great tool,
> Alkis Georgopoulos
> For anyone interested, the script is
> /opt/ltsp/i386/usr/share/initramfs-tools/scripts/ltsp_nbd
> and the patched line should be
> (echo -e "binary\nget /ltsp/i386/lts.conf"|tftp ${ROOTSERVER} >/dev/null 2>&1)

The next release will (correctly) support netascii.



More information about the Dnsmasq-discuss mailing list