[Dnsmasq-discuss] tftp: No netascii support

Άλκης Γεωργόπουλος alkisg at gmail.com
Fri May 23 17:47:42 BST 2008

I tried to use dnsmasq in Ubuntu hardy with LTSP (thin clients), to
replace dhcp3-server and tftp and of course to also add dns.

The clients didn't get a necessary file named "lts.conf" because the
script that tried to download it from tftp did:
tftp server
get lts.conf

This is interpreted as a "netascii" transfer and dnsmasq replied
"Unsupported operation" or something like that.
So I had to change this script to:
tftp server
get lts.conf

to force "octet" mode, which is supported, and everything worked like a charm.

So, to make it work out of the box in these situations, please support
"netascii" transfer mode, even if dnsmasq still sends the files as

Thanks for your great tool,
Alkis Georgopoulos

For anyone interested, the script is
and the patched line should be
(echo -e "binary\nget /ltsp/i386/lts.conf"|tftp ${ROOTSERVER} >/dev/null 2>&1)

More information about the Dnsmasq-discuss mailing list