[Dnsmasq-discuss] Problem with multiple Local Domains

Michael Rack dnsmasq.list at michaelrack.de
Thu Jun 12 08:27:14 BST 2008

There is a little mistake in your configuration.

According to the manpage

   -S, --local, 

you have to replace your option with


In this configuration, dnsmasq will answer queries directly from /etc/hosts.


web1-nospam at hst.me.uk schrieb:
> Hi,
> This is my first email to this list, so please be gentle! :)
> I've just upgraded my Ubuntu Server from 7.04 to 8.04 and consequently
> DNSMasq has updated to version "2.41-2Ubuntu1" acording to Synaptic
> Package manager.
> In my config file I had a line with multiple local domains - e.g.:
> local=/domain.name.one/ /domain.name.two/ /localhost/
> When the upgrade tried to restart the updated DNSMasq, DNSMasq failed to
> restart.  I have tried editing this line and it seems that if there is
> one domain listed it works fine, but with multiple domains listed,
> DNSMasq won't start.
> Is this a fault with my config, or has this feature become broken?
> Thanks in advance.
> Regards
> Stephen Roberts
> web1-nospam at hst.me.uk
> (do not de-mung the email address - it's valid!)
> _______________________________________________
> Dnsmasq-discuss mailing list
> Dnsmasq-discuss at lists.thekelleys.org.uk
> http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

More information about the Dnsmasq-discuss mailing list