[Dnsmasq-discuss] log-queries

Adam Pribyl pribyl at lowlevel.cz
Fri Jul 2 14:11:59 BST 2010

I am triing to debug some DNS problems on the network, therefore I came to 
enable log-queries in dnsmasq.conf, but it seems it is logging nothing.

What I've tried/read:
Enabling log-dhcp works ok. If I shut down dnsmasq, then I have no dns 
responses, so it is clear this is the service that is respoding. I am not 
using remote logging (as per FAQ I found). Tried to disable selinux, as it 
is causing sometimes weird problems, no inflence. Downloaded source from 
fedora - no patches, just make (enables dbus and changes some paths). With 
kill -10 dnsmasq I get statistic - queries are passed without errors to 
upstream DNS. But there is no query logged thru syslog-ng.

So instead debugging the DNS issue I am fighting dnsmasq now. I would be 
glad for any advice how to trace what's going on with dnsmasq log-queries.

I am at dnsmasq 2.52 on Fedora 12. Can not easily compile 2.55 at the 

Thank you

Adam Pribyl

More information about the Dnsmasq-discuss mailing list