[Dnsmasq-discuss] stop-dns-rebind Issue

dnsmasq at rkmorris.us dnsmasq at rkmorris.us
Sun Aug 29 03:43:37 BST 2010

 *      1024x768 
 *    Clean            false  false  false    EN-US  X-NONE  X-NONE                                       MicrosoftInternetExplorer4        
>                                                                                                                                                                                                                                                                                                                /* Style Definitions */  table.MsoNormalTable	{mso-style-name:"Table Normal";	mso-tstyle-rowband-size:0;	mso-tstyle-colband-size:0;	mso-style-noshow:yes;	mso-style-priority:99;	mso-style-qformat:yes;	mso-style-parent:"";	mso-padding-alt:0in 5.4pt 0in 5.4pt;	mso-para-margin:0in;	mso-para-margin-bottom:.0001pt;	mso-pagination:widow-orphan;	font-size:11.0pt;	font-family:"Calibri","sans-serif";	mso-ascii-font-family:Calibri;	mso-ascii-theme-font:minor-latin;	mso-hansi-font-family:Calibri;	mso-hansi-theme-font:minor-latin;	mso-bidi-font-family:"Times New Roman";	mso-bidi-theme-font:minor-bidi;}     Hi,
I recently tried updating my DD-WRT based router (which usesdnsmasq), and unfortunately I ran into quite a fewproblems. It seems to be related to a recent change that forces stop-dns-rebind. This is a good idea, but I need a workaround formy local machines … J.
I have a bit of a strange setup – it’s a longstory, but suffice to say that this is how I need things configured. I have acable modem/router, with a domain inside that (call it lanA).Then I have another router (with its WAN port connected to the cable modem/router,so WAN domain is lanA), which has client machineshanging off it (call this domain lanB).
My issue is that I cannot get names to resolve for lanA when I am in lanB, due tostop-dns-rebind (i.e. it used to work just fine). I’mtrying to figure out how to get this to work, but haven’t had any luck. Ihave tried using the server=/lanA/ andalso rebind-domain-ok=/lanA/, but neither seem towork (and they actually break my internet DNS from lanBalso … L). I also find that .lanB is getting added to nslookup requests in lanA (i.e. xxxx.lanA.lanB), but this could be due to also having expand-hosts included?
Can anyone help me out here?
… Russell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/attachments/20100828/e1f85afe/attachment-0001.html 

More information about the Dnsmasq-discuss mailing list