[Dnsmasq-discuss] stop-dns-rebind Issue

Simon Kelley simon at thekelleys.org.uk
Mon Aug 30 10:43:45 BST 2010


dnsmasq at rkmorris.us wrote:
> 
>     Hi,
> 
>      
> 
>     I recently tried updating my DD-WRT based router (which uses
>     dnsmasq), and unfortunately I ran into quite a few problems. It
>     seems to be related to a recent change that forces stop-dns-rebind.
>     This is a good idea, but I need a workaround for my local machines … J.
> 
>      
> 
>     I have a bit of a strange setup – it’s a long story, but suffice to
>     say that this is how I need things configured. I have a cable
>     modem/router, with a domain inside that (call it lanA). Then I have
>     another router (with its WAN port connected to the cable
>     modem/router, so WAN domain is lanA), which has client machines
>     hanging off it (call this domain lanB).
> 
>      
> 
>     My issue is that I cannot get names to resolve for lanA when I am in
>     lanB, due to stop-dns-rebind (i.e. it used to work just fine). I’m
>     trying to figure out how to get this to work, but haven’t had any
>     luck. I have tried using the server=/lanA/192.168.1.1 and also
>     rebind-domain-ok=/lanA/, but neither seem to work (and they actually
>     break my internet DNS from lanB also … L). I also find that .lanB is
>     getting added to nslookup requests in lanA (i.e. xxxx.lanA.lanB),
>     but this could be due to also having expand-hosts included?
> 

This smells like exactly the sort of problem that should be solved by 
-rebind-domain-ok, but your description of the current situation isn't 
too clear. Could you give us some more details, eg. does dnsmasq run on 
one or both of the routers, what are the IP address ranges, what queries 
fail and in what way.

Cheers,

Simon.



More information about the Dnsmasq-discuss mailing list