[Dnsmasq-discuss] dhcp-broadcast

Tyler Reese tyler.reese at taqua.com
Tue Sep 21 15:29:33 BST 2010

User error.

I am on RHEL 5, and it comes with dnsmasq-2.45.  The executable is located at /usr/sbin/dnsmasq.

I downloaded dnsmasq-2.55 (to get the dhcp-broadcast option) and ran 'make install'.  That put the 2.55 executable at /usr/local/sbin/dnsmasq.

The file /etc/init.d/dnsmasq is what I am using to start and stop dnsmasq.  That file was referencing /usr/sbin/dnsmasq, and 2.45 didn't know anything about dhcp-broadcast.  I fixed /etc/init.d/dnsmasq so that it references /usr/local/sbin/dnsmasq.  Now, I can just add 'dhcp-broadcast' to /etc/dnsmasq.conf and it works as expected.

It was working from the command line because 'which dnsmasq' showed /usr/local/sbin/dnsmasq.

From: dnsmasq-discuss-bounces at lists.thekelleys.org.uk [mailto:dnsmasq-discuss-bounces at lists.thekelleys.org.uk] On Behalf Of Tyler Reese
Sent: Tuesday, September 21, 2010 8:51 AM
To: dnsmasq-discuss at lists.thekelleys.org.uk
Subject: Re: [Dnsmasq-discuss] dhcp-broadcast

I tried this, but it made no difference.  Should it matter if a dnsmasq configuration option is in dnsmasq.conf or another file?

When I run 'dnsmasq --dhcp-broadcast' from the command line, it works as expected (unconditionally set the broadcast flag, which is what I need).
I also see this line in the log file:
Sep 20 16:59:44 adminportal dnsmasq-dhcp[25074]: 0 broadcast response
No matter how I try to set the option in the configuration file, I don't get a broadcast response.
I don't know the correct syntax for using this option in a configuration file (dnsmasq.conf or any other specified file).

From: richardvoigt at gmail.com [mailto:richardvoigt at gmail.com]
Sent: Tuesday, September 21, 2010 7:38 AM
To: Tyler Reese
Cc: dnsmasq-discuss at lists.thekelleys.org.uk
Subject: Re: [Dnsmasq-discuss] dhcp-broadcast

On Mon, Sep 20, 2010 at 8:39 PM, Tyler Reese <tyler.reese at taqua.com<mailto:tyler.reese at taqua.com>> wrote:
I'm trying to use this option to force the broadcast bootp flag to be set on bootp replies.  The only way I am able to make it work is to run 'dnsmasq --dhcp-broadcast' from the command line.  I want the dhcp-broadcast option to be used unconditionally.

I haven't found the correct way to add dhcp-broadcast to dnsmasq.conf in order to achieve the same thing.

In dnsmasq.conf, I have tried:

After making the change, I restart dnsmasq.  Neither one is making the broadcast bit get set, but again, it does work when I run dnsmasq from the command line.  What am I missing?  This is on dnsmasq-2.55.

I'm going to throw out a WAG that you're not editing the right dnsmasq.conf file.

Does forcing dnsmasq to read a particular config file using the -C command line option make any difference?

More information about the Dnsmasq-discuss mailing list