[Dnsmasq-discuss] [EXTERNAL] Re: Badly formatted "dhcp-boot=" line crashes dnsmsaq 2.85

Greg Wickham greg.wickham at kaust.edu.sa
Thu Aug 5 18:19:59 UTC 2021

Hi Matthias,

The OS is CentOS 7.9 on x86_64

Today I tried to re-create the issue and as you found it wasn't reproducible. I had made substantial changes to the dnsmasq.conf since the issue was reported.

I ran out of time today, but I'll have another go early next week and try to find the root (configuration) cause.


-----Original Message-----
From: Dnsmasq-discuss <dnsmasq-discuss-bounces at lists.thekelleys.org.uk> on behalf of Matthias Andree <matthias.andree at gmx.de>
Date: Wednesday, 4 August 2021 at 7:01 pm
To: "dnsmasq-discuss at lists.thekelleys.org.uk" <dnsmasq-discuss at lists.thekelleys.org.uk>
Subject: [EXTERNAL] Re: [Dnsmasq-discuss] Badly formatted "dhcp-boot=" line crashes dnsmsaq 2.85

    > But I did also try 2.85 before submitting this report and it crashes
    > whilst parsing the configuration file:
    > # /tmp/dnsmasq-2.85/src/dnsmasq -k -p0
    > Segmentation fault
    > #

    Greg, this appears to be insufficient information to reproduce the issue
    for me. What else is in your configuration? What operating system,
    version, architecture etc. are you on? What distribution?


More information about the Dnsmasq-discuss mailing list